Advanced Modelling with AgenaRisk

www.agenarisk.com

Copyright Agena Limited - © All rights reserved
Copyright Notice

© 2013 Agena Ltd. No part of this publication may be reproduced, published, stored in an electronic database, or transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise, for any purpose, without the prior written permission of Agena Ltd.

THERE IS NO WARRANTY OF ANY KIND FOR THE ACCURACY OR USEFULNESS OF THIS INFORMATION EXCEPT AS REQUIRED BY APPLICABLE LAW OR EXPRESSLY AGREED IN WRITING.
# Contents

Copyright Notice ii

1. Introduction 1

2. Models with Multiple Risk Objects 2
   2.1 Introducing the River Flooding Model 2
   2.2 Importing Models 2
   2.3 Connecting Risk Objects 4
   2.4 Running the Model 5
   2.5 More powerful methods of passing parameters between risk objects 6

3. Advanced Use of NPT Expressions and Simulation 9
   3.1 Introducing the Hypothesis Testing Model 9
   3.2 Using Conditional Statements 9
   3.3 Using Discrete Probability Distributions 12
   3.4 Running the Model 14
   3.5 Capturing Different Prior Assumptions 15
   3.6 Combining Data and Prior Assumptions 17
   3.7 Changing the Simulation Settings 18

4. Next Steps 20
1. Introduction

In the first half of this tutorial, you will learn how to build and use models that consist of more than one connected risk object. In the second half of the tutorial, you will explore NPT expressions and simulation in depth by building a powerful hypothesis-testing model.

Before working through this tutorial you should ensure that you have a sound working knowledge of AgenaRisk by working through the tutorials “Getting Started with AgenaRisk” and “Modelling with AgenaRisk”.
2. Models with Multiple Risk Objects

2.1 Introducing the River Flooding Model

1. The River Flooding model predicts whether a river will flood using information about the water level of a river, the amount of rainfall and the flood defences in place to prevent flooding.

2. The model is structured in such a way that it is possible to link together different instances of it to monitor the flood risk over time.

3. The amount of rainfall, together with the “prior” water level (i.e. before rainfall), influences the “post” water level (i.e. after rainfall). This “post” water level can then be used as the “prior” water level in a new instance of the model that represents the next time period.

4. The quality of flood defences and the water level after rainfall determine whether or not the river will flood. As with the “post” water level, the quality of the flood defences can be linked to the same node in the next time period.

2.2 Importing Models

1. Start AgenaRisk and open the Examples / Tutorials / River Flooding Basic Object.ast model.

2. Ensure that the River Flooding risk object is selected in the Risk Explorer. The model should look like the one in Figure 1.

3. Experiment with different values of Rain, Prior Water Level and Flood Defences to see what impact they have on the probability of a flood occurring.

4. When you are comfortable with how the basic model works, open the properties dialog for Prior Water Level and observe the Input Node box is checked and then click OK.

5. Repeat step 4 for Flood Defences.
6. Open the properties dialog for Post Water Level, verify that the Output Node box is ticked and click OK.

7. Repeat step 6 for Flood Defences Output.

8. Now save the model and call it Dynamic River Flooding.cmp.

9. Click on File → Import Model…, select the Dynamic River Flooding.cmp file that you just saved and click OK.

10. If you click on the root item in the Risk Explorer, you can see both models in the Risk Map:

   ![River Flooding model showing two risk objects after import](image)

11. Notice that the Risk Map shows both risk objects and that each risk object lists its input nodes (shown in blue) and output nodes (shown in green).

12. Import River Flooding.ast once more so that your model contains three identical risk objects.

13. In the Risk Explorer, rename the three objects T1, T2 and T3 (or even Day 1, Day 2 and Day 3). Then, in the Risk Map, line up the three objects horizontally so that they appear in chronological order. Your model should now look like the one shown in Figure 3.
The River Flooding model now contains three risk objects that are identical in all but name. Select each risk object in the Risk Explorer and verify that the Risk Map and Risk Table for each object look the same.

### 2.3 Connecting Risk Objects

1. In order to capture the time dimension in our model so that you can reason about how changes in the water level each day affect the risk of flooding, you need to connect the three risk objects together.

2. Click on the edge tool on the Risk Map toolbar:

3. Click on the *Post Water Level* segment of the *Day 1* risk object, move your mouse to the *Prior Water Level* segment of the *Day 2* risk object and click again. This creates a connection between the two risk objects:

![Figure 4 A link between two risk objects](image)

4. This link means that, whenever the model is calculated, the probabilities associated with each state of the *Post Water Level* node in *Day 1* are entered as probability distributions in
the Prior Water Level node in Day 2. In this way, the water level at the end of the first day becomes the water level at the beginning of the second day.

5. Draw another link between Flood Defences Output in Day 1 and Flood Defences in Day 2 so that the two risk objects look like those in Figure 5.

![Figure 5 Two connections between two risk objects](image)

6. Connect Day 2 with Day 3 in the same way:

![Figure 6 Three connected risk objects](image)

7. The model is now fully connected and can be used to assess how the risk of flooding changes over a three-day period.

2.4 Running the Model

1. Turn on the auto-calculate option by toggling the toolbar button:

![Auto-calculate button](image)

2. Close all risk graphs by selecting **Risk Graphs → Close All Graphs** from the menu bar or by clicking:

![Close all graphs button](image)

3. You are now going to use the model to explore how three days of high rainfall affects the risk of flooding and the quality of the flood defences.

4. Using the Risk Explorer, click on Day 1 and enter the observation **High Rainfall** on the Rain node.
5. Enter the same observation for **Day 2** and **Day 3**.

6. Return to **Day 1** in the Risk Explorer and double-click on the *Flood?* and *Flood Defences* nodes to show their risk graphs. Hold your mouse over the bars on the graphs to view the exact probability values of the states.

7. Click on **Day 2** in the Risk Explorer and show the same two risk graphs. Notice that the risk of flooding has increased and that the quality of the flood defences has degraded.

8. Click on **Day 3** in the Risk Explorer. Open the two risk graphs and observe that the risk of flooding has increased again and that the quality of the flood defences has degraded further still.

9. Suppose, now, that you want to see what effects remedial action on day 3 will have on the risk of flooding.

10. Ensuring that **Day 3** is still selected in the Risk Explorer, enter the observation **High** on the *Flood Defences* node.

11. Verify that the risk of flooding on day 3 has now been reduced by over **half**.

12. You might like to check your model against the solution which can be found in *Examples / Tutorials / River Flooding.ast* model.

### 2.5 More powerful methods of passing parameters between risk objects

Before we connected two risk objects by linking an output node of one to an input node of another. For this to work the two nodes had to be exactly the same type with exactly the same set of state values. The result of the linking was to pass the entire set of probability values from the input node to the output node. While this type of linking is still the default type of linking between risk objects in Versions 6.0 of AgenaRisk, you are not restricted to this. We have introduced new options for linking nodes in different risk objects. These are:

a) From a continuous node to a continuous node, you can either pass the full set of marginals (as was the previous default), or the value of a summary statistic as a constant. So, for example, the output node might represent a variable “height” and the input node might represent a variable “mean height”. In this case the link type you would select would be the summary statistic “Mean”.

b) From non-continuous node to a continuous node, you can pass the value of a single state as a constant. For example, the node “Flood” in the above tutorial is a Boolean node. We could link this to a continuous node (with a range 0 to 1) called “Flood probability” in another risk object and specify that the value passed is the value of “True”. If the value of the state “True” is 0.6 in the node “Flood” then the node “Flood probability” will have the value 0.6.

These new options require you to specify what you wish to pass. There is a link type option in node properties which can be accessed by right-clicking on the input node and selecting properties. You then select the link type option on the left hand side as shown in Figure 7.
The options in link type vary based upon whether it is option a or b. For option a you will see the dialogue in Figure 8.

Here, in addition to passing full marginals you have the option to select which summary statistic to pass.

For option b, you can select which state value to pass as shown in Figure 9.
Advanced Modelling with AgenaRisk

Please note that once you select and press apply, the selection of simulation checkbox will be set automatically.

Using a link type, passing a state or summary statistic, disables the node probability table and expression editing.
3. Advanced Use of NPT Expressions and Simulation

3.1 Introducing the Hypothesis Testing Model

1. Imagine we have two materials, A and B. From sampled data we wish to find which of the two has the best quality; that is, which material has the lowest probability of containing faults.

2. Let’s say that we take 200 samples of material A and 100 samples of material B. Of these we find that 10 of material A and 9 of material B are faulty.

3. Based on this data, can we truly believe that material A is better than material B? We need to test the so-called ‘null hypothesis’:

   \[ H_0: p_A = p_B \] (meaning there is no difference in the quality of the materials)

against the so-called ‘alternative hypothesis’:

   \[ H_1: p_A > p_B \] (meaning material A is better than material B)

3.2 Using Conditional Statements

1. Create a new model.

2. In this model, we are going to use the following colour scheme for nodes:

<table>
<thead>
<tr>
<th>Colour</th>
<th>Node Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Light Blue</td>
<td>Sample Nodes</td>
</tr>
<tr>
<td>Medium Blue</td>
<td>Probability Nodes</td>
</tr>
<tr>
<td>Dark Blue</td>
<td>Result Node</td>
</tr>
<tr>
<td>Green</td>
<td>Assumption Node</td>
</tr>
</tbody>
</table>

   Table 1 Colour scheme for Hypothesis Testing model

3. Add a new simulation node and change the following properties:

<table>
<thead>
<tr>
<th>Node Name</th>
<th>Probability Material A is Faulty</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unique Identifier</td>
<td>p_material_a_faulty</td>
</tr>
<tr>
<td>States</td>
<td>Single state: 0 – 1</td>
</tr>
<tr>
<td>Background Colour</td>
<td>Medium Blue</td>
</tr>
</tbody>
</table>

   Table 2 Properties for new node

4. Click Apply and then click OK on the information message that appears.
5. Switch to the **Node Probability Table** tab and choose **Uniform** in the drop-down box. Ensure that the **Lower Bound** field contains the value 0 and enter the value 1 in the **Upper Bound** field.

6. Switch to the **Graph Defaults** tab and ensure your graph properties dialog should look like the one shown in Figure 10.

![Figure 10 Properties for Probability Material A is Faulty node](image)

7. Click **OK**.

8. Copy the node you just created, paste the copy and move it so that it appears to the right of the original.

9. Change the **Node Name** of the new node to **Probability Material B is Faulty** and change the **Unique Identifier** to **p_material_b_faulty**.

10. Copy either of the two nodes and paste the copy beneath them.

11. Make the new node a child of the two existing nodes.

12. Change the **Node Name** of the new node to **p(A is faulty) – p(B is faulty)** and change the **Unique Identifier** to **a_b_difference**.

13. Make the lower bound of the single state – 1.0 instead of 0.0.

14. Change the type of expression on the node from **Uniform** to **Arithmetic** and, in the **Arithmetic Expression** text box, supply the following expression:

\[ p\_material\_a\_faulty - p\_material\_b\_faulty \]
Advanced Modelling with AgenaRisk

While you are typing the expression, you will notice that a red border surrounds the box. This indicates that the expression is invalid. If you hold your mouse over the box, a tooltip will appear that explains the cause of the problem. When the expression is complete and valid, the red border will disappear.

15. Click OK to complete node properties editing.

16. Create a new node below \( p(A \text{ is faulty}) - p(B \text{ is faulty}) \). This is going to be a conditional node that represents our two hypotheses and shows the probability of each of them being true.

17. Make the new node a child of \( p(A \text{ is faulty}) - p(B \text{ is faulty}) \).

18. Open the properties dialog for the new node.

19. Change the Node Name to Hypothesis, change the Unique Identifier to hypothesis.

20. Click Apply.

21. In the Node States tab, change the State Options drop down box to Customised. Type Material A better than Material B in the Positive Outcome field and type Material A not better than Material B in the Negative Outcome field. These two states correspond to the alternative and null hypotheses we want to test.

22. Click Apply.

23. Switch to the Node Probability Table tab and change the NPT Editing Type to Expression. Because this is a Boolean node, only one type of expression is available: Comparative.

24. In the Comparative Expression field, supply the following expression:

\[
\text{if(a\_b\_difference<0,"Material A better than Material B","Material A not better than Material B")}
\]

This expression means that, during calculation, the Material A better than Material B state will be chosen when the difference between the two probabilities is less than zero; otherwise, the Material A not better than Material B state will be chosen.

Make sure that you type the exact case-sensitive values of the states. Otherwise, when you generate the NPT, you will get an error message telling that you the NPT contains zero probabilities (because the NPT generator has been unable to match the states in the expression with the states of the node).

25. Click Apply.

26. In the Appearance tab change the background colour of the node to dark blue and in the Text Format tab, change the text colour to white.

27. Click Apply.
28. Click OK.

29. Run the model, display the risk graph for all nodes and verify that, in the absence of any information, the probability of material A being better than material b is slightly below 0.5. Your model should now look similar to the one in Figure 11 below.

![Figure 11](image)

Figure 11 Probabilities of Hypothesis node with no observations

3.3 Using Discrete Probability Distributions

1. You are now going to add nodes that represent the samples of the two materials taken during the test.

2. Create a new simulation node and make it a child of Probability Material A is Faulty.

3. Open the properties dialog for this node.

4. Change the Node Name to Material A: faults in 200 trials and change the Unique Identifier to a_faults.

5. Change the node type to Integer Interval. This type is appropriate because the number of faults observed during sampling is always going to be a whole number.

6. Click Apply.

7. Click on the Node Probability Table tab and select Binomial in the Expression Type drop-down box.

8. Enter the value 200 in the Number of Trials text box and enter the unique identifier of this node’s parent (p_material_a_faulty) in the Probability of Success text box. This means that the NPT generated for this node will be based on a Binomial distribution of faults.
observed. When you come to use the model, you will enter hard evidence on this node (in the form of a number of faulty samples observed). Then, via backward calculation, the model will update the probability of material A being faulty based on this evidence.

9. Click **Apply**.

10. Switch to the **Node States** tab, click on the **Remove all states** hyperlink and then check the **Make Upper Bound Positive Infinity** box. Set the **Upper Bound** value in first row as 9 and **Lower Bound** value in second row as 10. You should now have two states as shown in Figure 12.

![Figure 12 States on a new Integer Interval node](image)

11. Click **Apply**.

12. In the **Appearance** tab change the background colour of the node to light blue.

13. Switch to graph defaults and ensure the defaults are as shown in Figure 10 Properties for **Probability Material A is Faulty** node.

14. Click **OK**.

15. Copy **Material A: faults in 200 Trials** and paste it. When you copy and paste a node that has one or more parents, the new copy is connected to the same set of parents by default.

16. Select just the edge between **Probability Material A is Faulty** and the new node and delete it.

17. Move the new node over to the right of the Risk Map and make it a child of **Probability Material B is Faulty**.

18. Bring up the properties dialog for the new node.

19. Change the value of **Node Name** to **Material B: faults in 100 trials** and change the value of **Unique Identifier** to **b_faults**.

20. Click on the **Node Probability Table** tab. Notice that there is a red warning saying that the NPT needs to be regenerated and that there is a red border around the **Probability of**
Success text box. This is because the Binomial expression refers to the parent of the copied node. It needs to be rectified. Clear the Probability of Success box and enter p_material_b_faulty.

21. In the Number of Trials box, enter the value 100.

22. Click OK.

23. The model is now complete and should look similar to the one in Figure 13.

![Figure 13 Complete Hypothesis Testing model](image)

3.4 Running the Model

1. You can now use the model to test the two hypotheses.

2. If automatic calculation is not already activated, turn it on by toggling the toolbar button:

3. Enter the observation 10 for the node Material A: faults in 200 trials and enter the observation 9 for Material B: faults in 100 trials.

4. Look at the risk graph for the Hypothesis node. It should resemble the one in Figure 14.

![Figure 14 Risk graph of Hypothesis after evidence has been entered](image)
5. Verify that the probability of material A being better than material B is 0.9042 (i.e. roughly 90%).

6. Experiment with different numbers of samples to see how the result of the hypothesis test changes.

7. Save your model.

8. At this point you might want to compare your model against the solution which can be found in Examples / Tutorials / Hypothesis Testing.ast

3.5 Capturing Different Prior Assumptions

1. Close down any open risk graphs.

2. Create a new node at the top of the Risk Map. (Select all of the existing nodes and move them down if necessary.)

3. Open the properties dialog and change the following properties:

<table>
<thead>
<tr>
<th>Node Name</th>
<th>Prior Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unique Identifier</td>
<td>prior_type</td>
</tr>
<tr>
<td>Node Type</td>
<td>Labelled</td>
</tr>
<tr>
<td>States</td>
<td>Uniform, Beta</td>
</tr>
<tr>
<td>Background Colour</td>
<td>Green</td>
</tr>
</tbody>
</table>

Table 3 Properties for new node

4. Click OK.

5. Make Prior Type a parent of both Probability Material A is Faulty and Probability Material B is Faulty.

6. Open the properties dialog for Probability Material A is Faulty and switch to the Node Probability Table tab.

7. Change the NPT Editing Mode to Partitioned Expression and move the Prior Type entry in the left-hand list over to the right-hand list. You are going to supply one expression to be used when the state of Prior Type is Uniform and a different expression to be used when the state of Prior Type is Beta.

8. Double-click on the first cell in the expression table and, in the dialog that appears, specify a Uniform distribution with a Lower Bound of 0 and an Upper Bound of 1. This is equivalent to a prior assumption of complete ignorance about the likelihood of material A being faulty.

9. Click OK.

10. Double-click on the second cell in the expression table and, in the dialog that appears, specify a Beta distribution. Enter 1 for Alpha and 9 for Beta. Specify a Lower Bound of 0
and an **Upper Bound** of 1. This is equivalent to a prior assumption that there is a 1 in 10 chance of material A being faulty.

11. Click **OK**.

12. Define a partitioned expression on **Probability Material B is Faulty** just as you did for **Probability Material A is Faulty**. Specify it identically but make the **Alpha** parameter of the **Beta** distribution 2 and the **Beta** parameter 8. This encodes the assumption that there is a 1 in 5 chance of material B being faulty.

13. Clear the two existing observations from the model (by choosing **Tools → Clear Entered Data → All** from the menu bar).

14. Double-click on the two nodes whose NPTs you just modified and resize the nodes so that you can see the shapes of the graphs. Notice how the two prior assumptions differ:

   ![Figure 15: Hypothesis Testing model showing different prior assumptions](image)

15. Close the two risk graphs.

16. You are now going to compare two scenarios side-by-side: one in which the prior assumption is that the distribution of faults is uniform and the other in which a beta distribution of faults is assumed. The latter scenario might represent the opinion of a materials expert, for example.

17. Expand the Risk Scenarios panel and rename **Scenario 1** to **Uniform**.

18. Add a new scenario, rename it **Beta** and tick the **Active** checkbox.

19. Right-click on the **Prior Type** node and choose **Enter Observation → Uniform → Uniform**. By doing this, you are entering the observation that the **Prior Type** is **Uniform** in the scenario that you have named **Uniform**.

20. Right-click on the **Prior Type** node again and choose **Enter Observation → Beta → Beta**. By doing this, you are entering the observation that the **Prior Type** is **Beta** in the scenario that you have named **Beta**.

21. Double-click on the **Hypothesis** node to show its risk graph. It should look like the one shown in Figure 16.
Note that the two scenarios are plotted on it. Drag your mouse the points on the two lines and note the values of the two states for each scenario.

22. The data tells us that, in the absence of any sampling information, when we assume that the probabilities of faultiness are uniformly distributed, there is roughly a 50% chance that material A is better than material B.

23. However, if our materials expert believes that the prior faultiness probabilities are characterised by beta distributions – Beta(1,9) and Beta(2,8) for material A and material B respectively – then this results in a 76% chance that material A is better than material B.

### 3.6 Combining Data and Prior Assumptions

1. Open up the properties dialog for the node Material A: faults in 200 trials.

2. Change the name of the node to Material A: faults in 10 trials and change the Number of Trials parameter of the Binomial distribution from 200 to 10.

3. Click OK.

4. Open up the properties dialog for the node Material B: faults in 100 trials.

5. Change the name of the node to Material B: faults in 10 trials and change the Number of Trials parameter of the Binomial distribution from 100 to 10.

6. Click OK.

7. Turn off the auto-calculate feature (because you are about to enter four observations as a “batch” and you don’t need to calculate the model after each one).

8. For both the Uniform and the Beta scenario, enter an observation of 1 fault on Material A: faults in 10 trials.

9. For both the Uniform and the Beta scenario, enter an observation of 0 faults on Material B: faults in 10 trials.

10. Run a calculation. The graph for the Hypothesis node should now look like Figure 17.
Advanced Modelling with AgenaRisk

![Figure 17 Results of hypothesis test after entering sparse sample data](image)

11. Hold your mouse over the points of the graph to see the state probabilities.

12. Notice that, when we use uniform priors for the two faultiness probabilities, the sparse sample data tells us, with a confidence of roughly 76%, that material A is not better than material B. However, when we encode the opinion of an expert in the two Beta priors, these priors serve to supplement the sample data and tell us that the quality of the two materials is roughly equal.

13. Save your model.

14. At this point you might want to compare your model against the solution which can be found in Examples / Tutorials / Hypothesis Testing with Expert Judgement.ast

3.7 Changing the Simulation Settings

1. Close all the risk graphs.

2. Delete the Uniform scenario (by right-clicking on it in the Risk Scenarios panel and choosing Delete Selected Scenario(s)).

3. Remove the observation of 1 fault from Material A: faults in 10 trials. You can do this by right-clicking on the node and choosing Enter Observation → Beta → Clear Observation.

4. Run a calculation.

5. Open the risk graph for Material A: faults in 10 trials. Drag your mouse over the graph and observe that the mean number of faults is roughly 1 and that the variance is approximately 1.6.

6. Open the model properties by clicking on File → Model Properties from the menu bar and switch to the Simulation Settings tab.

7. Verify that the current value in the Maximum Number of Iterations field is 25. This setting determines how long you want simulation to continue for. The longer simulation goes on for, the more accurate it will be.

8. Change the value of Maximum Number of Iterations to 5 and then click OK.

9. Run a calculation.

10. Observe that the calculation takes less time but the results are less accurate: the mean number of faults is now 1.0664 and the variance is 2.2692.
11. Modelling often requires you to make a trade-off between speed and accuracy; in some situations accuracy will be more important and in others speed will be more important.
4. Next Steps

This tutorial has shown you some of the advanced aspects of building models using AgenaRisk. To learn more about the many types of problem AgenaRisk can be used to model, you should explore and interact with the range of well-documented example models that come with the software. To learn more about working with numeric nodes and simulation nodes you should read Chapter 6 of the manual.